Print Page

MOTU Digital Performer 4 Now Mac OS X 10.3 Compatible

1/12/2004

MOTU has announced that Digital Performer 4 is now Mac OS X 10.3 (Panther) compatible. The update for the application and plug-ins for version 4.1.2 canbe found by clicking here. (http://www.motu.com/english/download/index.html)

  Print Page