NI Spektral Delay 1.6, Vokator 1.2 - EMusician

NI Spektral Delay 1.6, Vokator 1.2

Native Instruments’ Spektral Delay 1.6 update and Vokator 1.2 update ($29 each) provide Intel-based Mac compatibility.
Author:
Publish date:
Social count:
0

Native Instruments’ Spektral Delay 1.6 update and Vokator 1.2 update ($29 each) provide Intel-based Mac compatibility.